Active Active   Unanswered Unanswered

gas guage not working on 1988 313 center console stinger

Your old Chris-Craft electrical system can be a challenge. If it runs on "juice" pose your questions and offer your advice here.

Moderators: Don Vogt, Al Benton, Don Ayers

corichie
Posts: 2
Joined: Sun Dec 07, 2008 1:21 pm
Contact:

gas guage not working on 1988 313 center console stinger

Post by corichie » Sun Dec 07, 2008 1:28 pm

i have searched high and wide to find the location of the sending unit for this model and cant figure out where it is placed. anyone with info on this topic would be greatly appreciated. i have changed out the guage so i know it must be the sender.

User avatar
Bill Basler
Posts: 1996
Joined: Thu Oct 20, 2005 4:48 pm
Location: Cedar Rapids, IA

Post by Bill Basler » Sun Dec 07, 2008 1:50 pm

Gas gauges that do not function properly are usually the sending unit.

There should be an access cover on the opt of your tank where the sending unit is. Remove the cover and unscrew the float/sending unit assembly. Be safe. You're dealing with gas fume, and gasoline.

Open the access panel, and move the float up and down on the travel arm and see if the guage moves accordingly. You can adjust it by bending the float arm or other component to read full, when the float is at the top of it's travel, and empty at the bottom.

If the guage doesn't move, you've likely got a sending unit that needs to be replaced.
Bill Basler

Bad Ass Boat
Posts: 87
Joined: Fri Apr 11, 2008 1:20 pm
Contact:

Sending unit

Post by Bad Ass Boat » Tue Mar 10, 2009 1:58 pm

Make sure your sending unit mounting is grounded when you lift up the unit to test it. Some are grounded to the tank if there metal, some have an external ground wire or strap. Just use a wire and two aligator clips on each end to ground the unit when testing.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests