Active Active   Unanswered Unanswered

Ignition problem

Keeping your powerboat under power is a lot easier with good advice. Post your power systems questions here.

Moderators: Don Ayers, Don Vogt, Al Benton

Post Reply
trebot
Posts: 72
Joined: Sun Mar 04, 2007 10:05 pm
Location: Lexington, Michigan
Contact:

Ignition problem

Post by trebot » Sun Aug 16, 2020 12:16 pm

Had an ongoing problem with very rough idle after a couple hours running. Changed over to Pertonix ignition, Flamethrower coil and Accell plug wires. Still had problem, but not as bad. Called tech service at Petronix and they suggested disconect + wire from coil and run new jumper wire to coil directly from battery. Said old wire tends to break down. My wiring is original from 1956. PROBLEM SOLVED!! Ran new wire from switch to + coil and everything works fine.

User avatar
Bilge Rat
Posts: 341
Joined: Thu Jul 16, 2015 4:02 pm

Re: Ignition problem

Post by Bilge Rat » Mon Aug 17, 2020 5:58 am

I had a similar problem on my Graymarine V8. Ran a new wire and soldered the wire to the funky tab connector that attaches to the points - problem solved.
1966 Lyman Cruisette 25 foot "Serenity Now!"
1953 Chris Craft Sportsman 22 foot "Summerwind"

jfrprops
Posts: 2089
Joined: Thu Dec 29, 2005 10:41 pm
Location: Powhatan Courthouse Virginia

Re: Ignition problem

Post by jfrprops » Wed Aug 19, 2020 6:58 am

good advice and research...thanks....John in Va
1980 Fairchild Scout 30
19?? custom Argentine Runabout 16'
1954 Whirlwind deluxe dual ckpt 16'
1921 Old Town Charles River 17' (founding Captain, James River Batteau Festival)

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests